How to upgrade a CDM database (manually)

Technote (troubleshooting)


Problem(Abstract)

Restored an earlier database on environment that has already been upgraded.
Database needs to be upgraded, to match the required version, before it can be access from CDM.

Symptom

2013-07-01 14:37:53,041 [7] ERROR Ibm.CognosDM.Services.Exceptions.CdmErrorHandler - (null) Exception Token: 'baee3d9b-074b-420a-86bd-2863f38d502d'.DB schema mismatch.

Known schema version: '10.2.1.17.8'. Actual schema version: '10.2.1.17.5' ? ? ? Ibm.CognosDM.Repositories.DbSchemaMismatchException: Exception Token: 'baee3d9b-074b-420a-86bd-2863f38d502d'.DB schema mismatch.
Known schema version: '10.2.1.17.8'. Actual schema version: '10.2.1.17.5'
.................

(Note. In this example, the error message indicates that the known version is 10.2.1 IF1 and the actual database version is 10.2.1)


Cause

Database and application are not on the same version.

Known schema version = CDM application version
Actual schema version = Database version


Environment

CDM 10.2.x.x

SQL Server

DB2


Resolving the problem

Upgrade the appropriate database(s) to match the application version. Not all customers will have all databases.


STEPS for CDM 10.2.2 and higher:
1. Open a command prompt
2. Navigate to "DBDeploymentTool" folder: cd C:\inetpub\wwwroot\CognosDM-Server\Tools\DBDeploymentTool>
3. Run the appropriate command:
- CDM CORE Database: Ibm.CognosDM.DeployDatabase.exe /S <SQL_Server> /DB <Core_DB> /AP "Ibm.CognosDM.Database.MSSQL.dll" /UPGRADE
- CDM CACHE Database: Ibm.CognosDM.DeployDatabase.exe /S <SQL_Server> /DB <Cache_DB> /AP "Ibm.CognosDM.CacheDatabase.MSSQL.dll" /UPGRADE
- CDM XBRL Database: Ibm.CognosDM.DeployDatabase.exe /S <SQL_Server> /DB <XBRL_DB> /AP "Ibm.CognosDM.Xbrl.Database.MSSQL.dll" /UPGRADE
- CDM FILING Database: Ibm.CognosDM.DeployDatabase.exe /S <SQL_Server> /DB <XBRL_DB> /AP "Ibm.CognosDM.Filing.Database.MSSQL.dll" /UPGRADE
Note. Replace "<>" according to your environment
4. Restart CognosDM-Server IIS application (ie: iisreset, or reboot application server)

The dll used on the upgrade commands can be for SQL Server or DB2. Use the one pertinent to your database software used for the CDM repository database(s). You can find the correct dll name under the DBDeploymentTool directory.

STEPS for CDM 10.2.0 and 10.2.1:
1. Open a command prompt
2. Navigate to "DBDeploymentTool" folder: cd C:\inetpub\wwwroot\CognosDM-Server\Tools\DBDeploymentTool>
3. Run the appropriate command:
- CDM CORE Database: Ibm.CognosDM.DeployDatabase.exe /S <SQL_Server> /DB <Core_DB> /VTS "core" /VT "CdmDBVersionInfo" /AP "Ibm.CognosDM.Database.dll" /UPGRADE
- CDM CACHE Database: Ibm.CognosDM.DeployDatabase.exe /S <SQL_Server> /DB <Cache_DB> /VT "CdmDBVersionInfo" /VTS "cache" /AP "Ibm.CognosDM.CacheDatabase.dll" /UPGRADE
- CDM XBRL Database: Ibm.CognosDM.DeployDatabase.exe /S <SQL_Server> /DB <XBRL_DB> /VT "DatabaseInfo" /VTS "xbrl" /AP "Ibm.CognosDM.Xbrl.Database.dll" /UPGRADE
Note. Replace "<>" according to your environment
4. Restart CognosDM-Server IIS application (ie: iisreset, or reboot application server)

Document information


More support for:

Cognos Disclosure Management
Cognos Disclosure Management

Software version:

10.2.1, 10.2.2, 10.2.3, 10.2.3.1, 10.2.4

Operating system(s):

Windows

Reference #:

1642704

Modified date:

2015-04-28

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