Cannot Launch Business Insight - Red X

Technote (troubleshooting)


Problem(Abstract)

When trying to launch Business Insight, a blank error with a red x is returned.

Cause

There are temp files required by Business Insight that belong to the root user in the temp\plugin-workspace\.config\org.eclipse.osgi directory, and the user starting Cognos does not have access to these files. This can occur when the product is installed as the root user, then the services are started as the root user at some point rather than the Cognos user who is supposed to be starting the services.

Resolving the problem

- Stop all the Cognos services.

- Find and delete the temp\plugin-workspace\.config\org.eclipse.osgi directory.

- Start the Cognos services as the Cognos user. This will recreate the temp\plugin-workspace\.config\org.eclipse.osgi directory under the permissions of the Cognos user rather than the root user.


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Document information


More support for:

Cognos Business Intelligence

Software version:

10.1.1

Operating system(s):

AIX

Software edition:

All Editions

Reference #:

1642480

Modified date:

2013-07-02

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