Troubleshooting
Problem
AWSBIK007E Error receiving data ../../src/jobman/monitor.c:373 error = Unknown error. : 10054. This error is received intermittently on a Windows Fault Tolerant Agent (FTA) and jobmon.exe crashes.
Symptom
19:00:50 24.06.2013|JOBMAN:+ AWSBIK007E Error receiving data ../../src/jobman/monitor.c:373 error = Unknown error. : 10054.
19:00:50 24.06.2013|JOBMAN:+
19:00:50 24.06.2013|JOBMAN:AWSBIK006E Error sending data ../..
/src/jobman/monitor.c:328 error = Unknown error. : 10054.
19:00:56 24.06.2013|BATCHMAN:AWSBHT032I Workstation SAPHVCLU is now inactive, no jobs will be scheduled.
19:01:02 24.06.2013|MAILMAN:AWSBCV018I #J0/Operator command: STOP
19:01:02 24.06.2013|MAILMAN:+
19:01:02 24.06.2013|MAILMAN:+ AWSBCV027I Unlinking from TWSMASTER
19:01:02 24.06.2013|MAILMAN:+
19:01:02 24.06.2013|MAILMAN:AWSBCV028I Unlinked from TWSMASTER, and will write to the PO box.
19:01:02 24.06.2013|MAILMAN:AWSBCV017I The total cpu time used by MAILMAN was 0 seconds
Cause
There can be several causes for this Windows error (network outage, TDI filter issue, firewall or network misconfiguration, alockout.dll, etc).
Environment
This error can occur on any Windows system (Windows 2003 R2, Windows 2008 R2, etc.)
Diagnosing The Problem
It is recommended that you research Microsoft online documentation or contact Microsoft support for information about the specific cause for the error on your system. See some of these links as an example:
http://support.microsoft.com/kb/945130
http://support.microsoft.com/kb/981344
http://support.microsoft.com/kb/260018
Resolving The Problem
The 10054 error should be investigated by your network and Windows administrators.
The errno = 10054 is a Windows return code which translates to the following error:
An existing connection was forcibly closed by the remote host.
In effect, the Windows operating system is identifying to Tivoli Workload Scheduler (TWS) that it has rejected the TCP operation because it was unable to perform the TCP action on the physical network. This results from conditions such as:
- TWS manager server cancellations of active client sessions
- high traffic on the network
- poorly configured network settings in the Windows machine NIC
- improperly configured routers, gateways, or firewalls, and other types of network related issues
Also, for a resolution to an issue with a Windows OS failure to retrieve the Windows Security Token, see Technote # 1613476 entitled "AWSBIK007E Error receiving data... JOBMON.exe crashes":
http://www-01.ibm.com/support/docview.wss?uid=swg21613476
Product Synonym
Maestro;TWS;TWA
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Document Information
Modified date:
17 June 2018
UID
swg21642382