Certificate mismatch during installation does not allow installation to finish

Technote (troubleshooting)


Problem(Abstract)

The condition that contributes to a certificate mismatch during installation and how to resolve the problem.

Symptom

During installation the following error messages are experienced:
Error 1: "key values mismatch (class CertificateDoesNotMatchPrivateKey)"
Error 2: "License.pvk does not match the license certificate"
Error 3: "Certificate Mismatch"


Cause

These error messages might indicate an old or partial installation of IEM has left behind old license remnants on the server or database causing old references to be used. This corrupts the attempt to install the new license.crt generated during installation.

Resolving the problem

Take the following steps to fix this problem:

    1. Run the IEM Remove Tool (https://www.ibm.com/developerworks/community/wikis/home?lang=en#!/wiki/Tivoli%20Endpoint%20Manager/page/TEM%20Remove%20Utility)
    2. Run the CleanupIEMRegistryKeys script (https://www.ibm.com/developerworks/community/wikis/home?lang=en#!/wiki/Tivoli%20Endpoint%20Manager/page/CleanupIEMRegistryKeys)
    3. Verify all BigFix / Tivoli Endpoint Manager / IBM Endpoint Manager files, directorys and registry keys have been deleted.
    4. Verify that BigFix/TEM/IEM services are no longer running on the server
    5. Search through the entire Windows registry on the server through registry and deleted every key and value that contains the string "BigFix" in it.
    6. Login to the database and drop the BFEnterprise and BESReporting databases.
    7. Delete the old ODBC DSN's found on the System DSN tab. For a 64 bit server OS, you will need to remove these entries through the 32 bit ODBC editor located at C:\Windows\SysWOW64\odbcad32.exe (DSN's to remove: bes_bfenterprise, bes_EnterpriseServer, enterprise_setup, and LocalBESReporting Server)
    8. Deleted all files in the C:\Windows\Temp folder.
    9. Restart the server machine.
    10. Download the production installers again here: http://support.bigfix.com/bes/install/downloadbes.html
    11. You will need a new license authorization file. Please contact TEM@dk.ibm.com and explain that you need a new license authorization file because the license.crt was corrupted during the last installation attempt.
    12. Use the new license authorization file provided by Licensing to perform a new installation.

      Note: This operation throws away all data in the database and starts the deployment over as a new fresh deployment. The operation is typically performed after a customer was using their server machine at one point in time to run a deployment that is no longer needed; however they failed to properly do a clean uninstall of the IEM software, leaving behind remnants.

Document information


More support for:

Tivoli Endpoint Manager

Software version:

Version Independent

Operating system(s):

Platform Independent

Reference #:

1642179

Modified date:

2015-01-13

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