IBM Cognos Analytic Server - CXMD not starting after every server reboot

Technote (troubleshooting)


Problem(Abstract)

The IBM Cognos Analytic Server - CXMD service is not starting after a server reboot. The service cannot be started without removing the tm1s.log file. Removing the tm1s.log file and a manual start solves the problem but it

occurs again after every server reboot.

Symptom

Error in tm1server.log;
2412 [] FATAL 2013-06-01 23:00:01.015 TM1.Transaction TM1TransactionLog::ProcessTransactionLog: Bad transaction log record, line number 1.
2412 [] FATAL 2013-06-01 23:00:01.015 TM1.Server Server terminated


Cause

The last operation performed by a regular server shutdown of a TM1 server ( IBM Cognos Analytic Server - CXMD service) session is to rename and move the TM1 server transaction logfile tm1s.log to a file named "tm1s<YYYYMMDDhhmmsss>.log" and to create a new empty TM1 server transaction logfile tm1s.log. When the next TM1 server session starts and the TM1 server transaction logfile tm1s.log is not empty, the previous TM1 server session had not been terminatd in a regular manner.

While stopping operating system or a service, Windows, by design, waits 20 seconds and then
kills the process. Thus, when TM1 server needs more data it will be killed. As a result transaction logfile tm1s.log is non-empty and may cause issues during next startup.
This is explained in details here: http://support.microsoft.com/kb/Q839262

Resolving the problem

Verify how many seconds it is required to stop IBM Cognos Analytic Server - CXMD service and reconfigure Windows operating system to wait a safe period of time before it will kill the tm1s.exe process.

To estimate the new value of WaitToKillServiceTimeout:
1. Please stop the IBM Cognos Analytic Server - CXMD from Cognos Express Manager.

2. Start it manually, as an application:
- open command shell, go to cd "C:\Program Files (x86)\IBM\Cognos Express\bin64" directory
- execute a command: tm1s.exe -z "C:\Program Files (x86)\IBM\Cognos Express\Xcelerator\Custom\TM1Data\CXMD"
- you will see a TM1 server window, when it will start completely you will see 'TM1 Server is ready' line in the window

3. Stop it by closing the window. Please confirm all questions if data has to be saved.
4. Monitor how long the tm1s.exe process works using Windows Task Manager
5. Add some safe margin to the result and configure new value of WaitToKillServiceTimeout as per below links:
http://support.microsoft.com/kb/Q146092
http://support.microsoft.com/kb/Q839262

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Document information


More support for:

Cognos Express

Software version:

9.0, 9.5, 10.1

Operating system(s):

Windows, Windows 2003 server

Software edition:

Advanced, All Editions, Datacenter, Edition Independent, Enterprise, Essential, Foundation, Personal, Standard, Workgroup, Workstation

Reference #:

1641890

Modified date:

2013-06-25

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