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Error ANR0222E database restoration

Troubleshooting


Problem

During a Tivoli Storage Manager server restore database operation, an error is encountered. ANR0222E Error opening for write disk definition file dsmserv.dbid. Error 2104 updating database ID file. ANR2032E RESTORE DB: Command failed - internal server error detected.

Cause

The server cannot update the file specified in the error message

Resolving The Problem

This error indicates the Tivoli Storage Manager server cannot update this file. Verify the following:

    1. This file exists on the system. In this case, the file dsmserv.dbid located in the server instance directory.
    2. Verify the DB2 instance owner user id has read/write permissions to the dsmserv.dbid file.
    3. Rename dsmserv.dbid to dsmserv.dbid.orig and create a new file with the same name. Copy the content of the original file to the newly created file. Try the database restoration again.

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"6.3","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21641644