IBM Support

SMC Console Not Working and Home page displaying NPE

Technote (troubleshooting)


Problem(Abstract)

Application header start showing the "Yantra 7.X " and System management console will stop working.

Symptom

Application Home Screen and System management console throwing the NPE :-


<Error ErrorCode="java.lang.NullPointerException"

ErrorDescription="Error description not available" ErrorRelatedMoreInfo="">

<Attribute Name="ErrorCode" Value="java.lang.NullPointerException"/>

<Attribute Name="ErrorDescription" Value="Error description not available"/>

<Error ErrorCode="java.lang.NullPointerException"

ErrorDescription="" ErrorRelatedMoreInfo="">

<Stack>java.lang.NullPointerException&#xd;

at com.yantra.ycp.hm.ui.backend.YHMMonitorServlet.getBackendLocale(YHMMonitorServlet.java:204)&#xd;

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)&#xd;

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:45)&#xd;

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)&#xd;


Cause

Locale Setup

Diagnosing the problem

Check getPreoperty API output with below XML ,if it shows the locale value with is not present in yfs_locale table .
<GetProperty PropertyName="yfs.install.localecode" />

Resolving the problem

Add the System locale to "yfs_locale" table or add the yfs.yfs.install.localecode property in customer_override.properties file with the with the system locale value
yfs.yfs.install.localecode=<Operating system locale value>

Document information

More support for: Sterling Order Management
Installation

Software version: 9.1, 9.2, 9.2.1

Operating system(s): AIX, HP-UX, Linux, Solaris, Windows, Windows Mobile

Software edition: All Editions

Reference #: 1641127

Modified date: 24 June 2015