Failure to determine the correct level of language packages to load during an upgrade.

Technote (troubleshooting)


Problem(Abstract)

A failure during upgrade related to language updates. Language packages are not upgraded to the appropriate level for the product, including pmps.

Resolving the problem

Language packages for a product, including pmps must be loaded manually to complete the upgrade.

You must upgrade the language packages manually, manually upgrade all pmp packages in the product payload, and then manually rebuild and redeploy application EAR files before restarting the application server hosting the product.

1) Log into the administrative workstation and upgrade the product language packages from the command-line, using a command with the following syntax:

c:\ibm\smp\bin\solutioninstaller.bat
-action upgrade
-pkgpath C:\IBM\SMP\pmp\CCMDB_Lang_Pkg_<upgrade_version_level>_<locale>
-license accept
-wasuser <wasadmin>
-waspwd ********
-dbuser <dbuser>
-dbpwd ******
-X<languageType> true
-XbsLevel <version_previously_installed>
-XbsUpgradeVersion <xliff_version_start>

<upgrade_version_level> would be 7.1.1.7 or higher
<locale> is the language locale
<languageType> is the type: addLang for additional language or baseLang for base language
<version_previously_installed> is the currently installed (prior to upgrade) level of the language package
<xliff_version_start> is in format Vxxxx-000 where xxxx is the next higher version number to the currently installed (prior to upgrade) level of the language package (for example V7116-000)

For example, if upgrading from 7.1.1.5 to 7.1.1.7, and Spanish had been installed as an additional language:

c:\ibm\smp\bin\solutioninstaller.bat
-action upgrade
-pkgpath C:\IBM\SMP\pmp\CCMDB_Lang_Pkg_7.1.1.7_Es.zip
-license accept
-wasuser <wasadmin>
-waspwd ********
-dbuser <dbuser>
-dbpwd ******
-XaddLang true
-XbsLevel 7.1.1.5
-XbsUpgradeVersion V7116-000


2) Identify and install all pmps from the payload that need to be installed or upgraded, including language pack artifact by inspecting the Payload.zip file for pmp packages. Use the solutioninstaller command to install or upgrade the packages.

For example, to upgrade to the Common pmp 7.1.1.7 package level, use the following syntax:
c:\ibm\smp\bin\solutioninstaller.bat
-action upgrade
-pkgpath C:\IBM\SMP\pmp\common_pmp_7.1.1.7.zip
-license accept
-wasuser <wasadmin>
-waspwd ********
-dbuser <dbuser>
-dbpwd ******


3) Navigate to the Maximo tools directory located at <Install_Home>\maximo\tools\maximo, and use the following command:

writereportprop.bat

4) Rebuild and redeploy the application EAR files, and them restart the application server.


Cross reference information
Segment Product Component Platform Version Edition
Systems and Asset Management Tivoli Change and Configuration Management Database AIX, Linux, Windows 7.2, 7.2.1, 7.2.2
Systems and Asset Management Tivoli Service Request Manager AIX, Linux, Windows 2003 server 7.2, 7.2.1
Systems and Asset Management Tivoli Asset Management for IT AIX, Linux, Windows 7.2, 7.2.1, 7.2.2

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

IBM Maximo Asset Management

Software version:

7.2, 7.2.1

Operating system(s):

Windows

Reference #:

1641061

Modified date:

2014-06-02

Translate my page

Machine Translation

Content navigation