IBM Support

Information on updating FileNet 5.2.0 for use with IBM Connections Content Manager (CCM) for IBM Connections 4.5

Preventive Service Planning


Abstract

This document contains information on how to update FileNet 5.2.0 for use with IBM Connections 4.5 Connections Content Manager (CCM)

Content

IBM Connections 4.5 environments using Connections Content Management (CCM) may need to upgrade the FileNet installation as part of the upgrade to a 4.5 CR. For information regarding IBM Connections 4.5 CRs, please review the Upgrade Strategy for IBM Connections 4.5 document.
Important
If you installed 5.2.0.3 Interim Fix 3 (IF003) after upgrading to IBM Connections 4.5 CR5, important files will have been overwritten. Please review the Connection 4.5 CR5: Restoring Sonata and Waltz files after updating FileNet Content Engine tech note.

Please review this table to find the FileNet version compatible with the Connections 4.5 CR version:

Required version for IBM Connections CR1 Required version for IBM Connections CR2 Required version for IBM Connections CR3 and CR4 Required version for IBM Connections CR5
FileNet Content Engine Server 5.2.0 FP1 5.2.0 FP1 5.2.0 FP1 minimum required. Fixpack 5.2.0.3 is recommended. 5.2.0 FP1 minimum required. 5.2.0.3 Interim Fix 3 (IF003) is recommended.
FileNet Content Engine Client 5.2.0 FP1 5.2.0 FP1 5.2.0 FP1 minimum required. Fixpack 5.2.0.3 is recommended. 5.2.0 FP1 minimum required. 5.2.0.3 Interim Fix 3 (IF003) is recommended.
FileNet Collaboration Services (FNCS) 2.0.0 FP1 2.0.0.1 Interim Fix 1 (IF1) *2.0.0.1 Interim Fix 2 (IF002) *2.0.0.1 Interim Fix 2 (IF002)

* FNCS 2.0.0.1 IF002 includes a variety of performance improvements specifically for IBM Connections Content Manager

Step-by-step FileNet upgrade guides:

4.5 CR1: Step-by-Step for applying CR1 for Connections 4.5 with Connections Content Manager

4.5 CR2 and above: Step-by-Step for applying CR2, CR3, CR4, or CR5 for Connections 4.5 with Connections Content Manager



FileNet download links:

Here are the direct download links for the FileNet fixpacks and interim fixes compatible with Connections:


note: FNCS 2.0.0.1 IF002 is not yet available for z/Linux

Important notes:

1. Each time you update FNCS, you will need to reinstall the CCM authentication filter into FNCS. To reinstall the authentication filter, please follow steps 16 - 18 in this topic: Configuring FileNet Collaboration Services for the Connections Content Manager.

2. When installing CCM for the first time on a Connections server with a CR deployed, you must first install the version supported by 4.5 then upgrade to the version that is supported by the currently installed CR.

3. For additional FileNet information, refer to the IBM FileNet P8 Platform Documentation.

Related information

Update strategy for IBM Connections 4.5

Document information

More support for: IBM Connections
Content Manager

Software version: 4.5

Operating system(s): AIX, Linux, Windows

Reference #: 1640797

Modified date: 22 October 2014


Translate this page: