Collecting Data: IBM Linked Library/ECM Widgets for IBM Connections

Technote (troubleshooting)


Problem

This TechNote provides information that can be used to ascertain the root-cause of problems with the Linked-library (ECM) Widget available for IBM Connections Communities.

Diagnosing the problem

Diagnostic process:



    Ascertain the answers to the following questions to establish the scope of the problem:

    Does the Linked Library component render?
    • If not then go thru the Data Collection sections for both Client & Server-side.

    Does the Linked Library component render but get an error page?
    • Is the message in the error page helpful? Does it tell you the Library is not found and you can try reconnecting to see if the server/library is available?
    • If not then go thru the Data Collection sections for both Client & Server-side.

    Do you get errors connecting to an ECM library/folder through the doc picker?
    • Is the message above the picker helpful? Have you configured the proxy correctly as described in the InfoCenter?
    • If not then go thru the Data Collection sections for both Client & Server-side.

    Do you get an error performing a specific action?
    • Does the error help or describe a particular limitation?
    • If not then go thru the Data Collection sections for both Client & Server-side.


Data Collection:
    Server-side:
      1. Enable the following trace-options on the WAS Server hosting the Communities Application:
        *=info: com.ibm.quickr.lw.*=all:com.ibm.lconn.librarywidget.*=all
      2. Reproduce the problem.
      3. Remove the trace-options set in Step 1.
      4. Submit the following files to IBM for analysis:
        a. Connections Communities WAS Server:
        • SystemOut.log
        • SystemErr.log
        • trace.log
        • library-config.xml
        • proxy-ecm-config.tpl

      - If your ECM Server resides on a separate WAS Server, then submit copies of its log-files as well:
        • SystemOut.log
        • SystemErr.log
    Client-side:

      a. First Option (if the problem occurs in Firefox):
          1. Install and enable Firebug.
          2. Load the Linked Library component.
          3. Open the Firebug console and add "debug=true" to the url parameters
          4. Then recreate the problem and capture the output in firebug.
      b. Second Option (if the problem is specific to a browser other than FF):
        Capture any error messages displayed or debug available through relevant script debugging consoles.
      c. If the problem involves actions with the ECM server. Install Fiddler2 (works with FF and IE) and capture the output of recreating the problem.

      d. Gather Browser Version and Client OS version. If running IE 8, is the browser in standards mode or compatibility mode? You can see this in IE by pressing F12. Then look in the upper left of the dialog that pops up.

      e. Capture screenshots which illustrate the problem.

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

IBM Connections
Communities

Software version:

3.0.1, 3.0.1.1, 4.0, 4.5

Operating system(s):

AIX, Linux, Linux zSeries, Windows

Software edition:

All Editions

Reference #:

1640365

Modified date:

2014-05-09

Translate my page

Machine Translation

Content navigation