IBM Support

Tivoli Storage Manager server does not start after password change

Troubleshooting


Problem

A Tivoli Storage Manager server instance service configured to run under a specific Windows account userid fails to start after the account password is changed.

Symptom

In this example, the Tivoli Storage Manager server instance, Server1, is configured to run with the "tsmadmin" Windows account userid. The Windows password for the "tsmadmin" Windows account is changed. The password is then changed in the "Log On" tab of the "TSM Server1" service. Following this, the server instance fails to start as a service. The server also fails to start in the foreground with the following error messages :

Tivoli Storage Manager for Windows
Version 6, Release 3, Level 3.000
Licensed Materials - Property of IBM
(C) Copyright IBM Corporation 1990, 2011.
All rights reserved.
U.S. Government Users Restricted Rights - Use, duplication or disclosure
restricted by GSA ADP Schedule Contract with IBM Corporation.
ANR0900I Processing options file H:\tsm\server1\dsmserv.opt.
ANR4726I The ICC support module has been loaded.
ANR0990I Server restart-recovery in progress.
ANR0151W Database manager fails to start. For more information about the failure, issue the db2start command.
ANR9999D_2785511358 RdbStartInstance(rdbinst.c:1310) Thread<0>: Add codes to msg DB_DATABASE_START_FAILED sqlCode -1397.
ANR9999D Thread<0> issued message 9999 from:
ANR9999D Thread<0> 000007FEE7A69839 OutDiagToCons()+159
ANR9999D Thread<0> 000007FEE7A633BC outDiagfExt()+fc
ANR9999D Thread<0> 000007FEE78372FB RdbStartInstance()+41b
ANR9999D Thread<0> 000007FEE779B522 dbiInit()+152
ANR9999D Thread<0> 000007FEE726D35D AdmServerMonitorThread()+73d
ANR9999D Thread<0> 000007FEE726EAAB admStartServer()+cb
ANR9999D Thread<0> 000007FEE7253474 adsmMain()+e84
ANR9999D Thread<0> 000000013F9D111B main()+9b dsmserv.c:241
ANR9999D Thread<0> 000000013F9D28DA __tmainCRTStartup()+11acrtexe.c:555
ANR9999D Thread<0> 000000007712F56D BaseThreadInitThunk()+d
ANR9999D Thread<0> 0000000077363281 RtlUserThreadStart()+21
ANR0172I rdbdb.c(1650): Error encountered performing action InstanceStop.
ANR0162W Supplemental database diagnostic information: -1032:SQLSTATE 57019:
The statement was not successful, because of a problem with a resource. :-1032
(SQL1032N No start database manager command was issued. SQLSTATE=57019).

Cause

Password not updated for DB2 service.

Resolving The Problem

When a Tivoli Storage Manager server instance is configured to run under a specific Windows account userid and the Windows account password is changed, it is necessary to update both the Tivoli Storage Manager instance service and the DB2 service. For example, when the server instance is Server1, it is necessary to update the password of the account under the "Log On" tab of the following two services :

  • TSM Server1
  • DB2 - DB2TSM1 - SERVER1

In this case, the password for the "TSM Server1" service was updated but the password for the "DB2 - DB2TSM1 - SERVER1" service was not updated.

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Supported Versions","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21640333