Embedded links in IBM FileNet P8eForms form not working in Single Sign On environment

Technote (troubleshooting)


Problem(Abstract)

Attempts to click the button which contains the hyperlink in P8eForms may see the login prompt instead the actual hyperlink contents

Symptom

The Citrix NetScaler, a type of load balancer, is used as the proxy for Single-Sign-On (SSO).

SSO credentials throughout all of IBM FileNet WorkplaceXT are retained, except for hyperlinks inside of the form. The form itself loads fine but when trying to access, for example, a Reference Guide button in the form contains the hyperlink, it brings up a login prompt.


Cause

There is a setting in the Citrix NetScaler to look so many bytes deep into the page and uses a regular expression to match and replace the host server name with the SSO name.

This depth setting, if was set at low range (e.g. 50KB - 100KB while the form was in higher range (e.g. 200KB - 300KB), can cause the issue, because the embedded hyperlinks were being too deep in the source HTML for the Citrix NetScaler to see and transform.

Environment

Citrix NetScaler load balancer, SSO

Resolving the problem

To resolve, modify the depth setting in the Citrix NetScaler to high range (e.g. 800KB)

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

FileNet eForms
Eforms for P8

Software version:

4.0.2

Operating system(s):

Windows XP

Reference #:

1639097

Modified date:

2013-05-29

Translate my page

Machine Translation

Content navigation