Troubleshooting
Problem
I installed IBM Content Analytics with Enterprise Search (ICA) and successfully applied fix pack 1. During the installation, I changed the default search server port to 21102. However, when I try to start the system or verify the installation with first steps, I see an error message.
Symptom
FFQG0024E An internal error occurred. Exception message: FFQQ0133E An error occurred while opening a connection to the servlet at host ibmserver.test.com and port 21102. Exception text: com.ibm.es.api.communication.utils.HTTPIOException
Cause
The specified port number isn't passed to the search server configuration during installation.
Resolving The Problem
Apply the following workaround steps:
- Stop ICA with the command esadmin system stopall.
- Modify the SearchServerPort property in the ES_INSTALL_ROOT/nodeinfo/es.cfg file to the new port value (21102) on all servers.
- Modify the nodeN.searchserverport property in the ES_NODE_ROOT/master_config/nodes.ini file.
- Change the port numbers as shown in the following example in the $ES_NODE_ROOT/master_config/searchserver/dock/dock.xml file:
...
<dock>
<searchHttpPort>21102</searchHttpPort>
...
<serverConfig>
...
<acceptorFactory ...>
<property name="defaultPort" value="21102"/>
... - Edit the hostname and port properties in $ES_NODE_ROOT/master_config/searchapp/{search, analytics}/config.properties (2 files). For example:
hostname=localhost
#port=8394
port=21102
(Note that #hostname=localhost should be there; remove the # character.) - Restart ICA. (If ICA is installed with WebSphere Application Server (WAS) or in a WAS clustering environment, also restart WAS instances.) For example, run the esadmin system stopall command and then the esadmin system startall command.
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Document Information
Modified date:
17 June 2018
UID
swg21638825