TEPS database is not created on SQLServer2008

Technote (troubleshooting)


Problem(Abstract)

After installing TEPS the TEPS DB is not created getting a pop-up error saying:
"Building the TEPS datasource failed possibly due to an incorrect user ID or password

Symptom

1. The TEPS and SA user and password are right

2. Datasource test are right

3. Running TEPS server configuration + Advanced + Utilities + Build TEPS database results in the following messages:
Attempting to create 64bit MSSQL data source: teps
Function executed, rc =[0], error mess: []
Data source [teps] successfully created.
Function executed, rc =[1], error mess: []
TEPSDataSource: Operation completed with errors.

4. systemout .log file shows this error:
SECJ0369E: Authentication failed when using LTPA. The exception is
com.ibm.websphere.wim.exception.PassowrdCheckFailedException:
CWWIM4512E The password match failed

5. TEPS log (*_cq_*.log) shows this error:
"failed when validating user through authentication service"

::CTProperty::Property Based Exception:1.0
---> name = Property Based Exception
----> -1020 = "PBE_hash-2105025385"
----> -2101a = -12000 L
----> -2102 = "User ID or password is invalid"
----> -2105 = "AUTH102"



Resolving the problem

Create a reg_sz entry named "DSCNPS2" in:

HKEY_LOCAL_MACHINE\SOFTWARE\Candle\KFW\CNPS\KFWSRV\Environment

with this value:

DSN=TEPS2;UID=TEPS;PWD=<password>;CONNECTION_LIMIT=100

and then to run "buildpresentation.bat" script which will create the TEPS DB .

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Tivoli Monitoring
Tivoli Distributed Monitoring

Software version:

All Versions

Operating system(s):

Windows

Reference #:

1638804

Modified date:

2014-04-22

Translate my page

Machine Translation

Content navigation