Troubleshooting
Problem
Attempts to run a performance test in Rational Integration Tester (RIT) of IBM Rational Test Workbench (RTW) result in "TestEngine did not start.".
Symptom
You see one of the following errors in the test console:
Probes failed to start - Failed to initialise DB Data Type mappings
[Error] Agent TestEngine did not start.
[Error] Error executing test: Unknown exception whilst attempting to execute a performance test, Failed to start all agents.
Cause
The Agent cannot access the project database schema. Access is necessary to save the test timings and probe statistics.
The most common cause is that the project settings are using the "localhost" address to access the project database. When a performance test starts, RIT sends a copy of the project to the Agent to run. The Agent attempts to access a database at "localhost" and fails.
The Agent computer might be unable to connect to the database server, due to networking issues such as firewalls.
Resolving The Problem
Consider the following steps.
- Verify the correct settings for the project results database in the RIT project.
- Verify that all machines running the Performance Agent are able to access the database.
STEP 1
- Click Project > Project Settings.
- Click Server Settings.
- Ensure that the Database URL contains a valid hostname or IP address.
- Click OK to save any changes.
STEP 2
- Open a command window on the Agent machine.
- Use the
telnet
command to test the network connection to the database.
For example if the database URL isjdbc:oracle:thin:@myserver:1521:XE
you . would execute:
telnet myserver 1521
- Consult with your network administrator to resolve the problem if you do not get a connection.
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Document Information
Modified date:
29 September 2018
UID
swg21638481