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Debugging the setup application process

Question & Answer


Question

How can you debug the IBM Rational Reporting for Development Intelligence (RRDI) application setup process?

Cause

You encounter error messages during setup. You would like to know details and the root cause of the error.

Answer

Perform the following steps to enable TRACE level debugging in the RRDI setup server:

1. Open the log4j.properties file found in the <RRDI_Install>/setup/logs/ folder

2. Enter a comment by placing a # symbol before the following line:

    #log4j.category.com.ibm.rational.rrdi.setup=ERROR, stdout, RRDI.LOG

3. Uncomment the following line by removing the # symbol before the following line:
    log4j.category.com.ibm.rational.rrdi.setup=TRACE, stdout, RRDI.LOG

    Attached is a sample copy of the log4j.properties with TRACE level debugging properly enabled.

    log4j.propertieslog4j.properties
4. Restart the setup server application

5. Reproduce the problem again. The TRACE information should now be logged to the setup log found under <RRDI_Install>/setup/logs/rrdi_setup.log>

[{"Product":{"code":"SSAVQ5","label":"Rational Reporting for Development Intelligence"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Not Applicable","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"2.0.1","Edition":"","Line of Business":{"code":"","label":""}}]

Document Information

Modified date:
29 September 2018

UID

swg21638376