IBM Support

JNDI cannot be accessed error logging into FileNet Workplace XT

Technote (troubleshooting)


Problem(Abstract)

Getting JNDI error while logging in Workplace XT to Content Engine on WebSphere 8.0.x

Symptom

Error Message:

com.filenet.api.exception.EngineRuntimeException;The JNDI cannot be accessed. [Code=null]; OMFC/TheNetwork/NoOp//API_UNEXPECTED_JNDI_ERROR

Exception Class:
com.filenet.wcm.api.RemoteServerException

Stack Trace:
com.filenet.wcm.api.RemoteServerException: com.filenet.api.exception.EngineRuntimeException;The JNDI cannot be accessed. [Code=null]; OMFC/TheNetwork/NoOp//API_UNEXPECTED_JNDI_ERROR
.....
Caused by: org.omg.CORBA.TRANSIENT: initial and forwarded IOR inaccessible vmcid: IBM minor code: E07 completed: No
at com.ibm.rmi.corba.ClientDelegate.createRequest (ClientDelegate.java:1276)
at com.ibm.CORBA.iiop.ClientDelegate.createRequest (ClientDelegate.java:1457)
at com.ibm.rmi.corba.ClientDelegate.createRequest (ClientDelegate.java:1164)
at com.ibm.CORBA.iiop.ClientDelegate.createRequest (ClientDelegate.java:1423)
at com.ibm.rmi.corba.ClientDelegate.request (ClientDelegate.java:1886)
at com.ibm.CORBA.iiop.ClientDelegate.request (ClientDelegate.java:1379)
at org.omg.CORBA.portable.ObjectImpl._request (ObjectImpl.java:458)
at com.ibm.WsnBootstrap._WsnNameServiceStub.getProperties (_WsnNameServiceStub.java:38)
at com.ibm.ws.naming.util.WsnInitCtxFactory.mergeWsnNSProperties (WsnInitCtxFactory.java:1549)
... 96 more


Cause

Websphere 8.0 introduced changes that now enables HTTP Only be default. This causes Java applet sessions to fail within Workplace XT

Diagnosing the problem

Error in the WebSphere Systemout.log:

[#/#/## 15:54:08:069 EDT] 0000001a CSIv2Effectiv W

JSAS1477W: SECURITY CLIENT/SERVER CONFIG MISMATCH: The client security configuration (sas.client.props or outbound settings in GUI) does not support the server security configuration for the following reasons:
ERROR 1: JSAS0809E: The current OID is RSA but this is not an Admin request.
ERROR 2: JSAS0603E: The server does not support SSL/TLS, but the client is configured to require it.

Further detail can be gathered by enabling WebSphere on one of the XT nodes per following instruction Here:

And use the following trace string :
*=info:ORBRas=all:Naming=all

Traces are logged in the trace.log in the WebSphere log directory.

Resolving the problem

Enable Java applet support. For step by step instructions please follow the steps outlined here.

Related information

Set up a trace on IBM WebSphere Application Server
Running P8 Client Applications with WebSphere Applicati

Document information

More support for: FileNet Content Manager
Workplace XT

Software version: 1.1.5

Operating system(s): AIX, HP-UX, Linux, Solaris, Windows

Reference #: 1637247

Modified date: 07 December 2016


Translate this page: