IBM Support

Read First: Collect MustGather data for IBM MessageSight

Troubleshooting


Problem

You are having a problem with your IBM MessageSight appliance and need to know what data to collect to find a solution.

Cause

By collecting MustGather data for your IBM MessageSight problem early and providing it to IBM when you open a Problem Management Record (PMR), you can help IBM MessageSight Support more quickly recognize known problems, identify workarounds, and diagnose new problems.

Resolving The Problem

Basic Information for all PMRs

In order to open an IBM MessageSight PMR, you must provide the following information:



  1. The IBM Customer Number (ICN) associated with the MessageSight purchase

  2. An email address and telephone number where you can be reached

  3. A clear description of the problem including any error messages

  4. The severity of the problem and its impact on your business

  5. The IBM MessageSight machine type and model number

  6. The IBM MessageSight machine serial number

  7. The IBM MessageSight firmware version

  8. Output from "platform must-gather"


Provide MustGather Output

The IBM MessageSight appliance includes a powerful command which will gather detailed information about your appliance configuration, log files, and other important diagnostic information. Sending output from the "platform must-gather" command when you open a PMR will help IBM MessageSight Support to understand your problem more quickly. To collect and send this output:



  1. Access the IBM MessageSight command line interface.


  2. Run the "platform must-gather" command to create a .tgz file containing diagnostic information. If you have a PMR open with IBM, include that number in the file name, for example:

    Console> platform must-gather PMR-12345,67R,890-May10.tgz



  3. Run the "file list" command. You should see the file you created as well as a separate collect-pd.txt file:

    Console> file list
    collect-pd.txt 676421 bytes created May 10, 2013 11:04:42 PM
    PMR-12345,67R,890-May10.tgz 33598707 bytes created May 10, 2013 11:04:56 PM



  4. Use the "file put" command to send the .tgz file to another computer by FTP or SCP. For example:

    Console> file put PMR-12345,67R,890-May10.tgz scp://ima@tux.example.com:/home/ima/
    The authenticity of host 'tux.example.com (192.168.2.4)' can't be established.
    RSA key fingerprint is b8:da:47:e2:5a:ff:b8:90:d9:81:a5:08:2e:68:61:1c.
    Are you sure you want to continue connecting (yes/no)?
    yes
    ima@tux.example.com's password:
    PMR-12345,67R,890-May10.tgz                          100%   32MB 231.1KB/s   02:22    



  5. Share the file with IBM MessageSight Support by sending it to the Enhanced Customer Data Repository (ECuRep).



  6. If the .tgz file is very large, you can send the collect-pd.txt file separately, then follow it with the .tgz file. The collect-pd.txt is included in the .tgz file, but IBM MessageSight Support can start reviewing it while the larger .tgz file is being transferred.



  7. Use the "file delete" command to remove the files, then exit the CLI:

    Console> file delete collect-pd.txt
    Console>
    file delete PMR-12345,67R,890-May10.tgz
    Console>
    exit



Please see the IBM Software Support Handbook for more information on working with IBM support.

[{"Product":{"code":"SSCGGQ","label":"IBM MessageSight"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Problem Determination","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"1.0;1.1;1.2","Edition":"All Editions","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21636884