Troubleshooting
Problem
Relationship between IP ADDR CHANGE and Navigator Update Pending
Symptom
Navigator Update Pending alerts were being flagged on the TEP for a number of Linux Servers. A large number of alerts were being generated every day for these servers.
Cause
The navigator update pending was being caused when the hostname associated with the Agents appears to the TEP with more than one TCP/IP address.
Environment
IBM Tivoli Monitoring Linux Agent
Diagnosing The Problem
The excessive updates are caused in part by the actions generating these messages in the TEPS logs, for example, <Host>_cq_KfwServices_<DateTime>-01.log
** IP ADDR CHANGE '<Agent>' '100.1.100.1' != '100.2.200.2'
A Hostname shown in the TEP is associated with two or more TCP/IP addresses. The associated TCP/IP addresses can only be identified in the TEPS log.
Resolving The Problem
We had to identify the TCP/IP addresses for each Server and then compare the ITM Agent configuration with the server Hostname and TCP/IP address.
We found that the install image used by the customer for the Linux Agent build was missing an environment variable which is used to uniquely identify the hostname for the remote Agents. Also, the ITM Agent configuration had the same hostname for each new ITM Agent configuration. The "Navigator Update Pending" condition was caused when many Linux servers having the ITM Agents configured with the same "Hostname". We resolved the problem by making the hostname for the remote Agents unique by using CTIRA_HOSTNAME and CTIRA_SYSTEM_NAME environment variables. Uniquely defining the hostname with each server's TCP/IP address.
Was this topic helpful?
Document Information
Modified date:
17 June 2018
UID
swg21636802