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A "No metadata found for installed package" message is seen by Installation Manager with WebSphere Enterprise Service Bus (WESB)

Troubleshooting


Problem

When you attempt to install WebSphere Enterprise Service Bus using Installation Manager and you select a destination node, you see an error that is similar to the following text: "No metadata found for installed package com.ibm.cic.agent 1.6.0.20120831_1216"

Cause

The cause of this issue is missing metadata in the Offerings subdirectory of the Installation Manager data directory (IM_DATADIR).

Resolving The Problem

To resolve this problem, complete the following steps:

  1. Locate the following files on a server where WebSphere Enterprise Service Bus installed correctly:
    • com.ibm.cic.agent 1.6.0.20120831_1216.jar
    • com.ibm.cic.agent 1.6.0.20120831_1216_SE.jar


      You can find the files in the {IM_DATADIR}/installRegistry/metadata/Offerings directory.

  2. Copy the files to the server where the error occurred.

Note: The IM_DATADIR directory is usually C:\Documents and Settings\All Users\Application Data\IBM\Installation Manager on Microsoft Windows operating systems and /var/ibm/InstallationManager on other operating systems.

[{"Product":{"code":"SS7J6S","label":"WebSphere Enterprise Service Bus"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Install","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"7.5.1;7.5;7.0","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Product Synonym

WESB

Document Information

Modified date:
15 June 2018

UID

swg21636797