IBM Support

Errors "GLPINS006E DB2 installation failed. GLPINS0891I refer to the ldapinst.log" reported when re-installing Tivoli Directory Server 6.3 on Microsoft Windows 2008

Troubleshooting


Problem

Errors "GLPINS006E DB2 installation failed. GLPINS0891I refer to the ldapinst.log" are reported when re-installing IBM Tivoli Directory Server 6.3 (TDS 6.3) on Microsoft Windows 2008

Symptom

Error "GLPINS006E DB2 installation failed. GLPINS0891I refer to the ldapinst.log" while attempting to install a second time, Tivoli Directory Server 6.3 on Microsoft Windows 2008

Cause

The first installation of TDS 6.3 created 2 groups: DB2USERS and DB2ADMNS

If you also installed Rational Directory Server, it created a user tdsadmin, added to these two groups.
These two groups prevent Tivoli Directory Server 6.3 to be installed again.

Diagnosing The Problem


Resolving The Problem

To solve the problem:

  1. Uninstall Rational Directory Server and Tivoli Directory Server.


  2. Delete the user tdsadmin


  3. Delete the 2 groups: DB2USERS and DB2ADMNS


  4. Reboot the machine or logout and login again in Windows


  5. Install Tivoli Directory Server 6.3 again

[{"Product":{"code":"SS4AKG","label":"Rational Directory Server"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Tivoli","Platform":[{"code":"PF033","label":"Windows"}],"Version":"5.2;5.2.0.1;5.2.0.2;5.2.1","Edition":"","Line of Business":{"code":"LOB15","label":"Integration"}}]

Document Information

Modified date:
16 June 2018

UID

swg21636043