Security Bulletin: Potential security vulnerability in WebSphere Application Server CVE-2013-1768 PM86780

Flash (Alert)


Abstract

Potential security vulnerability in WebSphere Application Server

Content

VULNERABILITY DETAILS:

CVE ID: CVE-2013-1768 (PM86780, PM86786, PM86788 and PM86791)

DESCRIPTION:
Deserialization of a maliciously crafted OpenJPA object can result in an executable file being written to the file system. An attacker needs to discover an unprotected server program to exploit this vulnerability. It then needs to exploit another unprotected server program to execute the file and gain access to the system. OpenJPA usage by itself does not introduce the vulnerability. The OpenJPA code ships with the WebSphere Application Server but WebSphere Application Server is NOT vulnerable to this issue. We recommend installing this fix or upgrading to a fix pack that contains this code as a proactive safeguard to ensure your environment is as secure as possible.

CVSS:


CVSS Base Score:10
CVSS Temporal Score: See
http://xforce.iss.net/xforce/xfdb/82268 for the current score
CVSS Environmental Score*: Undefined
CVSS String: (AV:N/AC:L/Au:N/C:C/I:C/A:C)


VERSIONS AFFECTED:

The following versions ship with the embedded OpenJPA code that has the vulnerability but it is not exploitable with WebSphere Application Server:
· Version 8.5.0.0 through 8.5.0.2 Full Profile and Liberty Profile
· Version 8.0.0.0 through 8.0.0.6
· Version 7.0.0.0 through 7.0.0.27
· OSGi Applications and JPA Feature Pack Version 1.0.0.1 through 1.0.0.9
· EJB 3.0 Feature Pack Version 6.1.0.15 through 6.1.0.45

REMEDIATION: The recommended solution is to apply the Fix Pack or PTF for each named product as soon as practical

Fix: Apply a Fix Pack or PTF containing the APARs, as noted below:

For IBM WebSphere Application Server:


    For V8.5.0.0 through 8.5.0.2 Full Profile: --OR--
    • Apply Fix Pack 8.5.5. or later.

    For V8.5.0.0 through 8.5.0.2 Liberty Profile: --OR--
    • Apply Fix Pack 8.5.5 or later.

    For V8.0 through 8.0.0.6: --OR--
    • Apply Fix Pack 8.0.0.7 or later.
    For V7.0 through 7.0.0.27: --OR--
    • Apply Fix Pack 7.0.0.29 or later.

For IBM WebSphere Application Server for IBM i operating systems:

For EJB 3.0 Feature Pack:

    For V6.1.0.15 through 6.1.0.45: --OR--
    • Apply EJB 3.0 Feature Pack 6.1.0.47 or later.

For OSGi and JPA Feature Pack:
    For V1.0.0.1 through 1.0.0.9: --OR--
    • Apply OSGi and JPA Feature Pack 1.0.0.11 or later (targeted to be available 13 January 2014)
· Workaround(s): None

· Mitigation(s): None

Important note: IBM strongly suggests that all System z customers be subscribed to the System z Security Portal to receive the latest critical System z security and integrity service. If you are not subscribed, see the instructions on the System z Security web site. Security and integrity APARs and associated fixes will be posted to this portal. IBM suggests reviewing the CVSS scores and applying all security or integrity fixes as soon as possible to minimize any potential risk.


For additional details and information on WebSphere Application Server product updates:
REFERENCES:
· Complete CVSS Guide
· On-line Calculator V2
· CVE-2013-1768 xforce.iss.net/xforce/xfdb/82268

CHANGE HISTORY:

  • 18 June 2013: Original copy published
  • 19 June 2013: Updated Description

*The CVSS Environment Score is customer environment specific and will ultimately impact the Overall CVSS Score. Customers can evaluate the impact of this vulnerability in their environments by accessing the links in the Reference section of this Flash.


Note:
According to the Forum of Incident Response and Security Teams (FIRST), the Common Vulnerability Scoring System (CVSS) is an "industry open standard designed to convey vulnerability severity and help to determine urgency and priority of response." IBM PROVIDES THE CVSS SCORES "AS IS" WITHOUT WARRANTY OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY


Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

WebSphere Application Server
Security

Software version:

7.0, 8.0, 8.5.5

Operating system(s):

AIX, HP-UX, IBM i, Linux, Solaris, Windows, i5/OS, z/OS

Software edition:

Advanced, Base, Express, Network Deployment

Reference #:

1635999

Modified date:

2013-06-18

Translate my page

Machine Translation

Content navigation