IBM Support

Inconsistency between Rational ClearQuest API and GUI clients for uploading files of the same name

Troubleshooting


Problem

With the IBM Rational ClearQuest Native, Eclipse and Web clients you cannot attach files of the same name to a record, whereas you can through the ClearQuest API.

Symptom

  • While ClearQuest clients; Windows, Eclipse and Web do not allow two or more attachments with same file name and different size/description, ClearQuest API allows this.
  • Through ClearQuest API, after commit() these attachments appear correctly as different files in attachment field.
  • Although display is correct, it is not possible to download the two different file versions to a local directory.
  • ClearQuest takes only one physical attachment file and downloads this version for every attachment entry in attachment field with same file name.

Cause

Inconsistency exists between the ClearQuest API and the GUI clients for uploading attachments of the same name to records. This issue was identified as a product defect under APAR PK59690.

Resolving The Problem

The API attach issue remains a product restriction. IBM Rational ClearQuest GUI clients already look for duplicates.

WORKAROUND

Modify your script to avoid uploading of attachments of the same file name through the IBM Rational ClearQuest API.

EXAMPLE

Add code to your script to verify if an attachment file name is duplicate, before the script calls the API.

[{"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"API","Platform":[{"code":"PF033","label":"Windows"},{"code":"PF016","label":"Linux"}],"Version":"8.0.0.5;8.0.0.4;8.0.0.3;8.0.0.2;8.0;8.0.0.1;7.1.2.9;7.1.2.8;7.1.2.7;7.1.2.6;7.1.2.5;7.1.2.4;7.1.2.3;7.1.2.2;7.1.2.1;7.1.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21635920