IBM Support

Unable to see the TM1 server in Architect/Perspectives/Web after a restart

Technote (troubleshooting)


Problem(Abstract)

The TM1 server is restarted and when users go to log in, the TM1 server is not showing up in Server Explorer or in TM1 Web.

Symptom

May see messages like this in the tm1server.log:
2932 [] INFO 2013-04-29 13:05:50.871 TM1.Comm.SSL Error connecting to remote machine

May also see this in the Event Viewer for a tm1sdx64 error:
E4) Cannot connect to admin server at host <machine name> and port 5498


Cause

The server log error implies that the server could not communicate with the Admin
Server. If the server cannot talk to the admin server, it will try to start one. If that fails the TM1 server will stop.

Resolving the problem

Make sure that the AdminHost in the tm1s.cfg file is pointing to the correct Admin server machine and that it is on a compatible version. For example, a 10.1.1 TM1 server cannot connect to a 9.5.2 admin host.

Make sure that the TM1 server machine can ping the TM1 Admin Server machine if they are on different machines - this could likely be a network issue and not a TM1 issue at all. Rebooting the machine may restore the network connection.

Make sure the Admin Server port number is not blocked or being used by another process.

Make sure that there is not more than one TM1 instance sharing the same PortNumber (located in the tm1s.cfg file).

Document information

More support for: Cognos TM1
TM1

Software version: 9.5.1, 9.5.2, 10.1.0, 10.1.1

Operating system(s): Windows

Reference #: 1635821

Modified date: 29 April 2013


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