Problem installing SupportPac IA94 XMS: Another version of this product is already installed.

Technote (troubleshooting)


Problem(Abstract)

You are trying to upgrade from XMS 2.0.1 to 2.0.2 (SupportPac IA94: IBM Message Service Client (XMS) for C/C++).

The previous version is removed from your system. When you try to install the new version, an error is seen about the previous version still being installed. The readme file tells you to do some editing on the vpd.properties file, but you are unable to locate the file.

Symptom

./setup.bin -i console
...
Another version of this product is already installed.
This installation cannot continue.
Please remove the existing version before attempting to install this
version.


Cause

The uninstall of the previous version did not clean up correctly the data related to the installed product. The data is in the /var/.com.zerog.registry.xml and not in the file vpd.properties. You can make same changes to this xml file.

Resolving the problem

Edit the /var/.com.zerog.registry.xml as you would the vpd.properties file from Step 5 in the "Know Problems" section of the readme.

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

WebSphere MQ
SupportPac

Software version:

7.0, 7.1, 7.5

Operating system(s):

Linux

Reference #:

1635154

Modified date:

2013-04-24

Translate my page

Machine Translation

Content navigation