IBM Support

Claim of Fastback Repository fails

Troubleshooting


Problem

Fastback server unable to claim repository

Symptom

When migrating Fastback server from one machine to another, claim of the repository can fail. In the ServerSFXX.log file, the following errors may occur:


MM/DD/YYYY HH:MM:SS¨( 934)->I4.GENERAL      :   
REP_DISPATCHER_S_ClaimRepository: Claim Started                                                                 
                                                                        
MM/DD/YYYY HH:MM:SS( 934)-->W8.CONF         :    CONF_S_OpenFile:
Can't open file Ýt:\FXSignature.txt¨ for Ý32770¨, Will retry in 2 seconds                                                                 

MM/DD/YYYY HH:MM:SS( 934)->I4.GENERAL      :   
REP_MGR_S_ClaimRepository: Claim is denied since the following repository object "t:\" .Can't find FXSignature.txt in repository on folder.                                                                 

Cause

Some or all of the following Fastback server configuration files were not copied into the server folder on the new machine:

  • History.txt
  • History.txt.sig
  • Orabr_Conf.txt
  • Orabr_Conf.txt.sig
  • Clog.sf
  • Users_enc.txt
  • Users_enc.txt.sig
  • Inprogress.txt
  • Inprogress.txt.sig
  • State.txt
  • State.txt.sig

Resolving The Problem

To resolve this issue, do the following:

  1. Copy the following files from the original FastBack Server to the new Fastback Server (these files are located in the Fastback server folder)
    • History.txt
    • History.txt.sig
    • Orabr_Conf.txt
    • Orabr_Conf.txt.sig
    • Clog.sf
    • Users_enc.txt
    • Users_enc.txt.sig
    • Inprogress.txt
    • Inprogress.txt.sig
    • State.txt
    • State.txt.sig
  2. Place copies of them in the following locations:
    • C:\Documents and Settings\All Users\Application Data\Tivoli\TSM\Fastback\Server
    • C:\Documents and Settings\All Users\Application Data\Tivoli\TSM\Fastback\Server\Mirror
  3. Stop/Start the Fastback server
  4. On the new Fastback server, go to:
    "General Configuration -> Storage Pool -> Repository Pool"
    right click on "Repository Pool" and select "Claim Repository".
This should resolve the problem and allow the claim to complete.

[{"Product":{"code":"SS9NU9","label":"Tivoli Storage Manager FastBack"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Supported Versions","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21634703