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How do I troubleshoot ADSI authentication requests with IBM Datacap Taskmaster Capture?

Question & Answer


Question

When my Taskmaster system is set to use ADSI authentication, and I suspect an issue with the call to the Active Directory server, how do I troubleshoot it?

Cause

With Active Directory (ADSI) authentication, the Taskmaster Server service must first make a call to the Active Directory server to get a list of groups for the Windows user that is logging in. If the results of that call are in question, a script can be run to make the call and pop up a window with the results.

Answer

To test the Active Directory call outside of Taskmaster:

  1. Copy ADQuery.vbs to a folder on the Taskmaster Server.
  2. Open a command prompt and navigate to that folder.
  3. Run the command: cscript ADQuery.vbs
  4. When prompted, enter the domain and user name for the user being authenticated.
  5. A window will hold the Active Directory response. If the request cannot be processed, an error will be listed in the command prompt instead.

One thing to be aware of is that when running this script, the request is being made by the currently logged in Windows user. When Taskmaster Server makes the request, it is being made using the identity of the Taskmaster Server service.

This query specifically emulates the ADSI call, but may be useful when troubleshooting LDAP authentication also.

ADQuery.vbsADQuery.vbs

[{"Product":{"code":"SSZRWV","label":"IBM Datacap"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Not Applicable","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.1.0","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21634557