Troubleshooting
Problem
IBM Rational Asset Manager (RAM) could not load its license client library.
Symptom
Rational Asset Manager displays this message in its configuration page.
Cause
This error can be caused by one of the following conditions:
1. The IBM WebSphere Application Server (WAS) shared library “sharedlib” is not configured correctly.
2. The ramSharedLibs/rlsibmratl812/* is missing or not accessible.
3. The rlsibmratl812 folder contains corrupted license drivers.
Resolving The Problem
By default the license server client is stored in
${USER_INSTALL_ROOT}/config/cells/<cells_name>/ramSharedLibs/rlsibmratl812
Note: ${USER_INSTALL_ROOT} is a WebSphere variable. By default this variable represents the home directory of your WebSphere profile.
To address the problem, follow these steps:
- Ensure that the files do exist in
${USER_INSTALL_ROOT}/config/cells/<cells_name>/ramSharedLibs/rlsibmratl812 and that WebSphere can access the file. - Ensure that the Shared Library is configured correctly and points to the right location.
- Ensure that server1’s “Class loader” does have the library reference “rlsibmratl812”
Once you have verified all the settings and saved all the new changes, restart WebSphere so it can pickup all the changes.
If the issue persists, contact IBM Support for further assistance.
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Document Information
Modified date:
16 June 2018
UID
swg21634416