IBM Support

BMXAA4211E - Database Error 2601 Has Occurred

Troubleshooting


Problem

While trying to save a work order a BMXAA4211E Database Error is displayed in the logs.

Symptom

Steps to reproduce:
1) Create a new work order.
2) Enter the required information.
3) Save the work order.

The result is that following error is displayed:

"Database error occurred when operating on Workview : Record *** Class = *** and Site = ***. Report Error to the owner of deployment."

Cause

This is happening because there may already be existing records within the database that Maximo is unaware of. This can be very old data, and it can be data that was not used. The reason this error occurs is because Maximo is trying to write to the database and that record (the primary key value) already exists.

Resolving The Problem

To resolve this issue, we suggest that you proceed to archive your data, and when doing so, you should select the option to remove the data that is being archived from the current database. When this is done, you should able to store the newly created work orders.

[{"Product":{"code":"SSLKT6","label":"IBM Maximo Asset Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Work Order Tracking","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF033","label":"Windows"},{"code":"PF027","label":"Solaris"},{"code":"PF016","label":"Linux"}],"Version":"6.2.1;6.2.2;6.2.3;6.2.4;6.2.5;6.2.6;6.2.7;6.2.8;7.1.1;7.5;7.6","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 June 2018

UID

swg21634274