java.lang.IllegalAccessError during Portal startup for version history

Technote (troubleshooting)


Problem

During the WebSphere_Portal JVM initialization, a check is made for any installed fixes and fixpacks. This technote describes how to resolve a java.lang.IllegalAccessError exception during this check.

Symptom

In the SystemOut.log, the following error can be seen:

=====================
[4/11/13 14:41:15:743 CDT] 00000019 ProductServic W com.ibm.wps.services.product.ProductServiceImpl init EJPFD0050W: An exception occurred while checking installation history, no information about interim fixes and fix packs is available!
java.lang.IllegalAccessError: Class com/ibm/websphere/product/IMVersionHelper illegally accessing "package private" member of class com/ibm/websphere/product/WPProduct
at com.ibm.websphere.product.IMVersionHelper.setupIMVersionHelper(IMVersionHelper.java:291)
at com.ibm.websphere.product.IMVersionHelper.<init>(IMVersionHelper.java:188)
=====================


Cause

This can happen if the Portal classloader has been changed from Parent Last (default) to Parent First. This causes WebSphere Application Server classes to override WebSphere Portal classes.

Environment

Portal v8.0.0.x
WAS v8.0.0.x

Diagnosing the problem

Classloader tracing (http://www-01.ibm.com/support/docview.wss?uid=swg21196187) revealed that the following class:

com.ibm.websphere.product.WASProduct

was being loaded from the wrong location. It should be loaded from PortalServer/prereq/prereq.product/shared/app/wpproduct.jar. In this case, it was being incorrectly loaded from AppServer/plugins/com.ibm.ws.runtime.jar.

Resolving the problem

To resolve the problem, follow these steps:

1. Log into the WebSphere Integrated Solutions Console
2. Navigate to Servers -> Server Types -> WebSphere Application Servers -> WebSphere_Portal -> Java and Process Management -> Class loader -> (classloader ID)
3. In the dropdown menu on this page, select "Classes loaded with parent class loader last"
4. Save changes (and synchronize if in cluster)
5. Restart the WebSphere_Portal server.

Rate this page:

(0 users)Average rating

Document information


More support for:

WebSphere Portal
Installation & Configuration

Software version:

8.0

Operating system(s):

AIX, Linux, Solaris, Windows

Reference #:

1634233

Modified date:

2013-04-17

Translate my page

Machine Translation

Content navigation