IBM Support

SI Application Does Not Start

Troubleshooting


Problem

Fresh installation of the system, the Sterling Integrator application will not start. The run.sh script is stuck at "Preregistering Event Listeners". The log files do not show any relevant errors and we have let this process runs for over 2 hours.

Symptom

Sterling B2B Integrator will not start

Last line presented on screen from the run.sh script is "Preregistering Event Listeners"

Only logs written out are the activemqBroker.log and preregistereventlisteners.log, neither contain errors

dump_info is successful

Cause

Incorrect entries in the /etc/hosts file

Environment

Unix/Linux

Resolving The Problem

Issue was with the IP address SI was binding to.

Customer installed the system by overriding the host IP address for the system.

The IP was the correct IP and was being reflected properly in the sandbox.cfg under INSTALL_IP=

However,EXT_HOST_ADDR showed a different incorrect IP. (which is pulled in at dynamically at install time)

We then reviewed the /etc/hosts file. The /etc/hosts file was mapping the incorrect IP to the DNS name.

nslookup of the correct IP address did resolve to the DNS name, however, on the Linux server itself, it was being overwritten in the /etc/hosts file.

[{"Product":{"code":"SS3JSW","label":"IBM Sterling B2B Integrator"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Installation","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21633780