How to bookmark diagrams and classes in Rational Software Architect

Technote (FAQ)


Question

How can you create bookmarks for diagrams, classes or methods in IBM Rational Software Architect (RSA) in order to be able to quickly navigate to those resources later?

Cause

You would like to create bookmarks for diagrams or other modeling resources the same way you do for a given line of code.

Answer

ANSWER

Select the element you wish to bookmark in the Project Explorer view and then click the Edit > Add Bookmark... menu.

You can then see all your bookmarks in the Bookmarks View that can be opened via the Window > Show view -> Bookmarks menu or through the CTRL + 3 shortcut by typingbookmark and selecting the Bookmarks view.

Elements such as classes and activities can also be bookmarked from within a diagram. If you select such an element in a diagram, click the Edit > Add bookmark menu and it will be bookmarked. Later, if you open the bookmark, the diagram will be displayed and the chosen element will be selected.

Cross reference information
Segment Product Component Platform Version Edition
Software Development Rational Software Architect for WebSphere Software Modeling: Diagrams Linux, Windows 8.0.4, 8.0.4.1, 8.0.4.2, 8.5, 8.5.1

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Rational Software Architect
Modeling: Diagrams

Software version:

8.0.4, 8.0.4.1, 8.0.4.2, 8.5, 8.5.1

Operating system(s):

Linux, Windows

Reference #:

1633398

Modified date:

2013-04-16

Translate my page

Machine Translation

Content navigation