IBM Support

Unable to execute Analyst macro on Cognos Server

Troubleshooting


Problem

Client is unable to execute an existing Analyst macro in Planning Administrator or in Analyst from the Planning Administration/Analyst/Planning server using the Cognos services account. The same macro (as well as other macros) from a different library executes successfully in both Planning Administrator or in Analyst.

Symptom

Details of error on Planning - Administrator console:

Machine details: 'Domain\ Server Name'

User details: 'Domain\user

Process ID/Thread ID: xxxx.xxxx

Unable to execute Analyst Macro step 'Execute Analyst Macro.'

Unable to execute macro 'GUID'

Unable to invoke 'APMacroExecute2'.

Function "GetFile" caused a "FILE TIED" on line 8

See the log file for further details.

Planningerrorlog.csv Error:

Unable to invoke 'APMacroExecute2'.
Function "GetFile" caused a "FILE TIED" on line 8
See the log file for further details.

Cause

Full administrative rights to "Cognos", the domain account on the Cognos server were not fully granted.

Environment

Windows 2008 R2 64-bit

EP 10.1 hotsite 609

Resolving The Problem

Full administrative rights to "Cognos", the domain account on the Cognos server were fully granted.

Following this, the Analyst Macro executed successfully from the Analyst and the Planning Administrator on the Cognos Planning/Planning Administration/Analyst server using the Cognos services account.

[{"Product":{"code":"SSPN2D","label":"Cognos Planning"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Analyst","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1;10.1.1","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21633294