Portal startup fails after enabling or disabling developer mode

Technote (troubleshooting)


Problem

To enable or disable Portal to start in developer mode. The following tasks may be executed:

./ConfigEngine.sh|bat enable-develop-mode-startup-performance -DWasPassword=password

./ConfigEngine.sh|bat disable-develop-mode-startup-performance -DWasPassword=password

After executing either of these tasks, Portal may fail to start.


Symptom

In startServer.log and on the console, the following error is seen:

========================================
[1/22/13 23:20:10:267 PST] 00000000 ManagerAdmin I TRAS0017I: The startup trace state is *=info:com.ibm.*=all.
[1/22/13 23:20:10:282 PST] 00000000 ManagerAdmin I TRAS0018I: The trace state has changed. The new trace state is *=info.
[1/22/13 23:20:10:360 PST] 00000000 AdminTool A ADMU0128I: Starting tool with the wp_profile profile
[1/22/13 23:20:10:360 PST] 00000000 AdminTool A ADMU3100I: Reading configuration for server: WebSphere_Portal
[1/22/13 23:20:13:746 PST] 00000000 AdminTool A ADMU3200I: Server launched. Waiting for initialization status.
[1/22/13 23:20:13:777 PST] 00000000 AdminTool A ADMU3011E: Server launched but failed initialization. startServer.log, SystemOut.log(or job log in zOS) and other log files under C:\IBM\WebSphere\wp_profile\logs\WebSphere_Portal should contain failure information.

========================================

In the SystemOut.log, there is no entry for the startup failure. Instead, this error is found in native_stderr.log:

========================================
JVMJ9GC019E -Xmn too large for -Xms
JVMJ9VM015W Initialization error for library j9gc24(2): Failed to initialize
Could not create the Java virtual machine.

========================================

Cause

These tasks modify the initial heap size for the Portal JVM. Enabling developer mode sets the initial heap size to 768M. Disabling it sets it to 50M. If you have done any tuning to it, the above tasks may overwrite the values with ones that are not suited for your environment.

Diagnosing the problem

Check the above mentioned logs in <wp_profile root>/logs/WebSphere_Portal

Resolving the problem

1. If the WAS admin console is available (or Dmgr, if clustered), perform these steps:

a. Log into the WAS admin console

b. Navigate to Servers -> Application Servers -> WebSphere_Portal -> Server Infrastructure -> Java and Process Management -> Process Definition -> Java Virtual Machine

c. Set the Initial Heap Size to a value suited for your environment

d. Apply and Save the changes.

e. Restart Portal

2. If the WAS admin console is unavailable, perform these steps:

a. Backup the following file:

<wp_profile root>/config/cells/<cell name>/nodes/<node name>/servers/WebSphere_Portal/server.xml

b. Open the server.xml specified above in a text editor

c. Search for the string initialHeapSize

d. Change the value to one suited for your environment

e. Save and close the file

f. Restart Portal



Rate this page:

(0 users)Average rating

Document information


More support for:

WebSphere Portal
Installation & Configuration

Software version:

6.1, 7.0, 8.0

Operating system(s):

AIX, IBM i, Linux, Solaris, Windows, z/OS

Software edition:

Enable, Express, Extend, Server

Reference #:

1633181

Modified date:

2013-04-03

Translate my page

Machine Translation

Content navigation