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How to install and configure local help system for RSA RealTime Edition 8.5.1

Question & Answer


Question

How can you successfully install and configure local help system for IBM Rational Software Architect (RSA) RealTime Edition 8.5.1?

Cause

From RSA RealTime Edition 8.5.1, several changes have been introduced in product help system. You may encounter some issues when trying to configure the local help system on 8.5.1 with the same steps previously done for older versions.

Answer

To install and configure local help system for RSA RealTime Edition 8.5.1 successfully , you need to note following changes.

  • Mechanism to upload local help content is changed.

    In version 8.5 and earlier, you download the corresponding compressed help file from IBM document updatesite and expand the file locally. Then you point the location of file site.xml to upload the local help system. Since 8.5.1, you are required to directly point the downloaded zip file(RSART8.5.1_updateSite.zip) to the local help upload interface.

    See below image please.

  • Local help system WORK folder location is changed

    In previous versions (version 8.5 or earlier versions), the WORK folder used for help system is located at <Product Install Root Dir>\help\work. Since 8.5.1, the WORK folder is located at configuration\com.ibm.ut.ic.server\help
    You can simply delete the existed WORK folder to perform fresh re-installation of local help system.

  • Change in Eclipse framework network connection interface

    If your system is using proxy server, even you have successfully installed the local help content, you still could experience some issues during the tool initialising the local help server. (below image is one of the examples)



    You should first check the network connection settings from the menu
    [Window] > [Preferences], then expand category [General] > [Network Connections]

    For environment using proxy server, you should choose [Direct] or [Manual] option as the [Active Provider]. If you choose [Native] option instead, please make sure "127.0.0.1" is listed in the "Proxy bypass" section and the corresponding item is ticked as per below image.


For more information about setting on Network connections, refers to the IBM Rational Software Architect RealTime Edition Information Center documentation for your installed version in the following topic.

Other methods available for you to access help content are
  • Remote help
  • Intranet help

You can find more detailed information from product information center.

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Document Information

Modified date:
16 June 2018

UID

swg21632783