Issue with print icon missing in iNotes calendar print preview

Technote (troubleshooting)


Problem

When attempting to print a calendar entry in iNotes 8.5.3 using Adobe Reader version 10 or 11, the print icon does not display, If you hover over the preview, you only have the options "Show previous page", "Show next page", "Zoom out", "Zoom in" and "Show Adobe reader Toolbar",but not the print option. Therefore the users believe they cannot Print.

- The issue occurs with any browser.


Symptom

Print button is missing from the pdf viewer of the iNotes web page.


Steps to reproduce:
1) Access a iNotes mail85(8.5.3) mail file via any browser
2) Switch to the Calendar view
3) Choose to Print by selecting the Print icon
4) The Print Preview will launch in Adobe ( Adobe Reader 10/11)
5) Select Refresh Preview
===> there is no option to Print

Cause

Change to Adobe Reader code in Adobe Reader 10

Environment

Issue has been found testing with Adobe Reader version 10, and also occurs with Adobe 11.

Diagnosing the problem

To proceed with an iNotes print operation in the browser, Adobe Reader is required. The iNotes calendar view PDF print preview just shows the PDF reader embedded in iNotes web page. The display of the print icon on the embedded PDF, is done by Adobe Reader.


The issue seems to be caused by a change to where the print icon is displayed in the pdf viewer in these newer versions of Adobe Reader, as in previous versions e.g 9.5.0 the print icons displayed at the top of the viewer and therefore this issue did not occur.

Regarding the behaviour of Adobe Reader 10, it doesn't prevent the users from printing. The behaviour of Adobe Reader 10 is inconvenient for the users. But if the users do the additional steps, the users can print the generated PDF.


Resolving the problem

The issue can be worked around as follows:

    1. Revert to an earlier version of Adobe Reader for e.g 9.5.0 where the print icon is on the top rather than the bottom of the pdf viewer.
    2. Using iNotes with Adobe 10 requires additional steps to print, you can:
      (a) Click "show Adobe Reader toolbar" -> select "Tools" -> you can then select "Print" .
        (You can set the "Adobe Reader" toolbar to always be open in the embedded pdf window in iNotes, by making the following configuration change in the "Adobe Reader" applications menu "Edit - Preferences - Internet" and un-check "Display in Read Mode by default")
      or
        (b) Right-click in the Print Preview window and it will allow you to print.

    As the issue is caused by a change to the Adobe Reader code, affected users should report the issue to Adobe


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    Document information


    More support for:

    IBM iNotes
    Printing

    Software version:

    8.5.3, 8.5.3.1, 8.5.3.2, 8.5.3.3

    Operating system(s):

    Mac OS X, Windows

    Reference #:

    1632681

    Modified date:

    2013-03-28

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