MustGather: Issues with reporting when using Rational Team Concert

Technote (troubleshooting)


Problem(Abstract)

This document will assist you in collecting the data necessary to diagnose and resolve IBM Rational Team Concert (RTC) reporting issues.

Cause


This MustGather will assist you in collecting the data necessary to help you diagnose and resolve the issue. If you are unable to determine the root cause using the information collected, you should open a PMR with IBM Rational Support for further investigation providing the data collected.


Resolving the problem

You can use the IBM Support Assistant Lite (ISA Lite) Data Collector tool to quickly collect diagnostic files, such as log files, configuration files or to run traces. This tool is bundled with RTC 4.x and above. ISA Lite collects information about your Jazz Team Server environment and stores the information in a .zip archive file. If you have a need to open a service request with IBM Rational Support for further assistance, you can send the archive file with the data collection so that they can help diagnose and fix problems.


The information below should be gathered in addition to the normal information and log gathering done by ISA Lite.





General Information

  • Does the behavior occur for all reports or just one report?

  • Capture a screenshot of the error or incorrect behavior

  • Expected results (how did you determine that the report is incorrect). For example, an export of query output, screenshot of the report from before the problem, and other expected results.

  • Ensure that the ETLs are running successfully (see the section below on ETLs)

Collaborative Lifecycle Management (CLM) Java Out of Box ETLs

  • Collect the ETL log files located in <server install directory>/logs and named <app>-etl.log

    Refer to the Monitoring and Troubleshooting Guide for IBM Rational Collaborative Lifecycle Management (CLM) topic in the Deployment wiki on Jazz.net for further information about the applications logs.
  • Capture a screenshot of the Data Collection Job Status page for EACH application:

    https://<servername>:9443/<app>/admin#action=com.ibm.team.reportsManagement.etlStatus

  • Ensure that the Jobs have not been disabled from the Data Collection Jobs page for EACH application:

    https://<servername>:<port>/<app context>/admin#action=jazz.viewPage&id=com.ibm.team.reports.reportsManagementPage

Additional resources

Why do my ETLs take so long to run: https://jazz.net/wiki/bin/view/Deployment/WhyDoMyETLsTakeSoLongToRun


Leverage the Jazz Community

Jazz and Rational Team Concert have an active community that can provide you with additional resources. Browse and contribute to the User forums, contribute to the Team Blog and review the Team wiki.
Refer to technote 1319600 for details and links.

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Document information


More support for:

Rational Team Concert
Reports

Software version:

4.0, 4.0.1, 4.0.2

Operating system(s):

AIX, Linux, Solaris, Windows

Reference #:

1632550

Modified date:

2014-04-16

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