SDK repeated login / logoff actions may cause an Axis failure in software on Logon.

Technote (troubleshooting)


Problem(Abstract)

A client SDK Application is set to repeatedly login and logoff with the same user for each report or job scheduled or executed. During running of many actions occasionally an Axis Fault appears on logon.

Symptom

Code throws exception and halts operation.


Cause

The BiBus header is a very dynamic header and the internal components that make up IBM Cognos product version 8.x and 10.x use the header for relaying status and messages. Within the processing of SDK developed code, when the system gets into a heavy loading state, it is possible that the header contains information that it should not, for the next exectution action.

Environment

Any SDK environment.

Diagnosing the problem

Soap Traces of the SDK code runs can point out the issue.

Resolving the problem

A failure to logon after repeatedly logon / logoff for all these reports can be prevented by ensuring that the cmservice header is cleared before doing the logon.

Implement the clearing of the BiBus, and alter the logon() code block as shown below, recompile the code and Test in the environment.




if (cmService==null) {
      logger.debug("cmService is null - connecting ");
      connect(0);
     }
         
     try {
           ((Stub)cmService).clearHeaders();   <==== Added to prevent a certain BiBus state from propagating.
          cmService.logon(xmlCredentials, null);
          
SOAPHeaderElement temp = ((Stub) cmService).getResponseHeader("http://developer.cognos.com/schemas/bibus/3/", "biBusHeader");

BiBusHeader cmBiBusHeader = (BiBusHeader) temp.getValueAsType(new QName("http://developer.cognos.com/schemas/bibus/3/",                "biBusHeader"));

((Stub) cmService).setHeader("http://developer.cognos.com/schemas/bibus/3/", "biBusHeader", cmBiBusHeader);


Any further issues with the SDK code should be investigated by performing Soap Traces and contacting IBM Customer Support.

Related information

TN1339588 - How to setup and monitor SOAP messages from

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Document information


More support for:

Cognos Business Intelligence
Software Development Kit

Software version:

8.3, 8.4, 8.4.1, 10.1, 10.1.1, 10.2

Operating system(s):

AIX, HP-UX, Linux, Solaris, Windows

Software edition:

Edition Independent

Reference #:

1632348

Modified date:

2013-12-20

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