IBM Support

Cannot see the Where Clause edit field in View/Manage Queries Dialog box

Troubleshooting


Problem

User cannot see the SQL Where Clause edit field in View/Manage Queries Dialog box.

Symptom

When trying to open the detail of a query to edit the SQL where clause using the Arrow icon, the SQL Clause edit field is not visible, like in the screenshot below.

Cause

From Maximo 7.5.0.3 onwards, the SQL query Clause edit field is related to the sigoption "BMXVIEWMANAGEWHER". It means that users cannot see the SQL Where Clause edit field if users do not have access to the "BMXVIEWMANAGEWHER" option.

The "BMXVIEWMANAGEWHER" option is the Sigoption to control the visibility of the Detail section in the View/Manage Queries dialog box.

Resolving The Problem

Please follow the steps below in order to fix your issue:

Check if the user has access to the BMXVIEWMANAGEWHER option. Run the SQL query below (change XXX to your userid):

SELECT * FROM APPLICATIONAUTH WHERE GROUPNAME IN ( SELECT GROUPNAME FROM GROUPUSER

WHERE USERID = 'XXX' ) AND OPTIONNAME = 'BMXVIEWMANAGEWHER' AND APP = 'WOTRACK';

If no record is returned, you need to grant access for BMXVIEWMANAGEWHER to XXX user's group.

- Go to the Security Group application.

- Open the Security Group that user XXX belongs to.

- Go to the Applications tab - Work Order Tracking application.

Find the option "Sigoption to control the visibility of the Detail section in View/Manage Queries Dialog" and check the "Grant Access?" checkbox like below.




Save the record. Log back in to Maximo.

You can now see the SQL Where Clause edit field like below.

[{"Product":{"code":"SSLKT6","label":"IBM Maximo Asset Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Security Groups","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"7.5","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 June 2018

UID

swg21632283