IBM Support

Unable to Log into OpenPages Due to an Error 404 - Not Found Message

Troubleshooting


Problem

After refreshing an environment or loading a new custom deliverable, the OpenPages services are not coming up properly. The login page is display an 'Error 404--Not Found' message.

Symptom

After verifying that the end user is using the correct URL, the end user is receiving the following message when attempting to log into the OpenPages application:

Error 404--Not Found


From RFC 2068 Hypertext Transfer Protocol -- HTTP/1.1:
10.4.5 404 Not Found

The server has not found anything matching the Request-URI. No indication is given of whether the condition is temporary or permanent.

If the server does not wish to make this information available to the client, the status code 403 (Forbidden) can be used instead. The 410 (Gone) status code SHOULD be used if the server knows, through some internally configurable mechanism, that an old resource is permanently unavailable and has no forwarding address.

Cause

One of the OpenPages JSPs is not compiling properly.

Diagnosing The Problem

Verify that the proper URL is being used. The 'Error 404--Not Found' message is to be expected when an incorrect URL is entered.

Resolving The Problem

The IT Administrator should open and review each log file that is part of the standard set. See 'Related Information' section for a listing of the standard set of log files.

The OpenPages log files may indicate which log file is not compiling correctly. If the issue was caused by a recent deliverable, the IT Administrator should contact the Managing Consultant (MC) to have an OpenPages Consulting Engineer review the issue.

If the issue is related to a refresh of an environment, the IT administrator should verify:

    • All the custom JSPs were refreshed / updated properly.
    • The openpages-ext.jar was refreshed / updated properly.
If the issue still persists, the IT administrator can attempt to:
    • Clear the WebLogic cache (see TechNote # 1591907 for steps on clearing the application cache).
    • Review the refresh procedures for possible errors (see TechNote # 1627965 for common refresh issues).
    • Rename the problematic JSP (from the logs) to .bak (For example. PolicyHelper.jsp.bak).

[{"Product":{"code":"SSFUEU","label":"IBM OpenPages with Watson"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"6.2;6.1.0.1;6.1;6.0.1.5;6.0.1.4;6.0.1.3;6.0.1.2;6.0.1.1;6.0.1;6.0;5.5.3;5.5.2","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21632259