IBM Support

OPCAMOD stopped working after upgrade

Troubleshooting


Problem

After upgrading z/OS, NetView, and SAz/OS, a user Rexx exec that uses the OPCAMOD command was no longer working.

Symptom

No error message, but noticed the following security message when the command was manually issued (expected because the user ID was not authorized):


EQQX121E You are not authorized to UPDATE on FIXED RESOURCE CP - FROM=RAD3

Cause

NetView Update authority to a resource called IBMOPC was lost.

Diagnosing The Problem

First used the SAz/OS Global trace (AOCTRACE ON) to isolate the two Rexx execs giving the non zero return codes.

Then used the following Debug commands to confirm the OPCAMOD command was also receiving a similar EQQX121E message:



AOCTRACE EVJRVSU0,ON
AOCTRACE EVJRYRQ0,ON

Resolving The Problem

This issue was resolved by granting NetView Update authority in RACF to the IBMOPC resource.

Note: As per the AOFEXC21 topic, you can use the command INGOPC REQ=MOD.

[{"Product":{"code":"SSWRCJ","label":"IBM Tivoli System Automation for z\/OS"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"--","Platform":[{"code":"PF035","label":"z\/OS"}],"Version":"3.5","Edition":"","Line of Business":{"code":"LOB35","label":"Mainframe SW"}}]

Document Information

Modified date:
08 August 2018

UID

swg21632034