Troubleshooting
Problem
When using the ISM configuration GUI to resync, an error dialog pops up with the message 'Unknown reason'.
Symptom
When an ISM profile is updated using the ISM GUI editor, the ISM agent Status is out of sync, and an error pop up 'Unknown Reason' is displayed when a resynch is attempted.
The ISM GUI editor shows the error 'Resynch failed' in the bottom left corner:
A resynch with the ismconfig.sh command line works successfully:
[root@itcamft1 classes]# ./ismconfig.sh -config -resyncall
Internet Service Monitoring Configuration
Copyright (c) IBM 2011, 2012
Version: ITCAM_ISM_7.4.0.1_0286
Cause
The ISM configuration GUI is using a cached version of the old .jar file.
Diagnosing The Problem
For example, after installing ITCAM for Transactions 7.4 Fixpack 1 + IF0002, the version of the ISM GUI should be 7.4.0.1_0286.
This is displayed in the bottom left corner of the ISM configuration GUI at start up:
If the ISM GUI has cached an old jar file, the version is different.
Resolving The Problem
To resolve the problem, clear the java cache. Here is how to clear the cache for the Java Web Start TEP client.
Exit the ISM GUI and close the TEP.
On the system where the TEP client is started, open a command prompt, and start the Java Web Start viewer:
C:\>javaws –viewer
In the Java Control Panel, click the ‘Settings’ button:
Next, click the ‘Delete Files’ button:
The Delete Files dialog is displayed. Check 'Trace and Log files', and
'Cached Applications and Applets', then click ‘OK’.
Restart the TEP, and launch the ISM GUI. The problem is now resolved, and the ‘Unknown Reason’ error is not displayed when profiles are updated.
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Document Information
Modified date:
17 June 2018
UID
swg21631843