The Connect:Express request table became full.

Technote (troubleshooting)


Problem(Abstract)

The Connect:Express request table became full because remote partner run in a loop sending the same file again and again.

Cause

On the incoming connection, 1 session is opened.

The transfer is rejected with TRC=5005L PRC=2216 (record length is null, and file is not variable type)
and with Pesit IDT (transfer interrupt) command sent back to partner.
The logic is to keep the session open and wait for a close or a new transfer from the partner.
The incoming request is kept in the request table for a possible restart from the partner.

The partner retries to send the file again (without trying a restart, this could be checked using journal file, transfer ID should be different each time) and fails with the same error.


Resolving the problem

A solution is to purge those external requests using the UE1 exit, based on the return codes for a transfer .

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Sterling Connect:Express for z/OS

Software version:

4.3

Operating system(s):

z/OS

Reference #:

1631806

Modified date:

2013-03-22

Translate my page

Machine Translation

Content navigation