CTGIN2186E: Creation of one or more JMS queues failed during Fix Pack Install

Technote (troubleshooting)


Problem(Abstract)

During the 7.5.0.4 fix pack install you may receive the error CTGIN2186E: Creation of one or more JMS queues failed

Symptom

The fix pack will show the following error on screen showing it cannot find the queue and errors out trying to create it when the queue is already there.

ENTER:checkJMSQueue. scope= ctgCell01(cells/ctgCell01|cell.xml#Cell_1) , qName= CQIN ,jndiName= jms/maximo/int/queues/cqin
EXIT: checkJMSQueue(scope,qName,jndiName). The queue was not found. It will be created. RC=0

Creating the JMSQueue -> CQIN
exception: TYPE: com.ibm.ws.scripting.ScriptingException VALUE: com.ibm.ws.scripting.ScriptingException: com.ibm.websphere.management.exception.ConnectorException

org.apache.soap.SOAPException: [SOAPException: faultCode=SOAP-ENV:Client; msg=com.ibm.ws.messaging.admin.command.AdminCommandException
Server stack trace
JMXTransformException java.lang.ClassNotFoundException: com.ibm.ws.messaging.admin.command.AdminCommandException


Cause

This can be caused by the JMS queue configuration having the NAMES created in lower case when the install is looking for upper case it cannot find them.

Diagnosing the problem

From the WebSphere console expand resources and select Queues. Set the Scope to Cell=ctgCell01.

From the list ensure the following queues exist and the name is in upper case (if the error shows the queues in upper case)

CQIN
CQINERR
SQIN
SQOUT

Resolving the problem

If the queues exist but are in lower case modify the names to be upper case. If they do not exist create then four queues mentioned above.

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Document information


More support for:

IBM Maximo Asset Management
Maximo Install Tool

Software version:

7.5

Operating system(s):

Platform Independent

Reference #:

1631640

Modified date:

2014-02-13

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