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No data available for MS Request/Transaction Reports

Troubleshooting


Problem

I can see no data available for a MS Request/Transaction report, while I suspect there are data in the relevant OCTIGATE database table, what should I check?

Cause

Either the report definition is incorrect, or there are no corresponding data in the database.

Resolving The Problem

First of all, make sure that filtering options are correctly defined, in particular that you don't use a wildcard "*" into the Request/Transaction Name field, this is a possible mistake: an empty field is the correct way to specify no filter.



Moreover, you can find out what exact report SQL is by changing report trace log level to DEBUG_MIN.
Follow these steps:

1. Open MSVE log properties file: $MS_HOME/etc/cynlogging.properties

2. Find line: CYN.trc.ve.par.level, and set it as:

CYN.trc.ve.par.level=DEBUG_MIN

3. Restart MSVE WebSphere server

4. Bring up MSVE, run the report again

5. You will find the SQL statement MSVE executed from MSVE trace log (by default, MSVE trace log is under /var/ibm/tivoli/common/CYN/logs).

This way you can use that SQL statement to query database directly to see if there are data returned.

[{"Product":{"code":"SSDTFJ","label":"Tivoli Composite Application Manager for Application Diagnostics"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"ITCAM for APPLICATION DIAGNOSTICS Managing Server","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"7.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21631489