Connection Failed error message connecting to TM1 from Cognos Insight

Technote (troubleshooting)


Problem(Abstract)

When trying to connect Cognos Insight to TM1 the error message "Connection Failed" appears.

If the "Next" button is hit another error appears: "Could not establish connection to the IBM Cognos TM1 Server: Could not log on with the provided credentials."

There are also no prompts for a Username and Password to be entered.

Cause

IntegratedSecurityMode=2 or IntegratedSecurityMode=3 or IntegratedSecurityMode=4 is set.

Currently the TM1 Application Server does not support these Integrated Security Modes.


Resolving the problem

Check the tm1s.cfg file that the TM1 server is using.

Currently only IntegratedSecurityMode=1 & IntegratedSecurityMode=5 are supported by the TM1 Application Server. This includes connecting Cognos Insight & Cognos Performance Modeler to the TM1 Server.


Related information

TM1 10.1.1 supported environments

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Document information


More support for:

Cognos Insight

Software version:

10.1, 10.1.1, 10.2

Operating system(s):

Windows

Reference #:

1628890

Modified date:

2013-04-02

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