IBM Support

Start server fails with ADMU3011E Exception in thread "main" java.security.AccessControlException: Access denied

Technote (troubleshooting)


Problem(Abstract)

When trying to start server, it fails with error ADMU3011E

Symptom

When the properties folder inside the profile got deleted or moved for some reason, the server would not be able to start. And it fails with the following security exception stack in the native_stderr.log:

ADMU3011E: Server launched but failed initialization in the startServer.log and the following Exception in the native_stderr.log:


Exception in thread "main" java.security.AccessControlException: Access denied (java.util.PropertyPermission eclipse.exitcode read)
at java.security.AccessController.checkPermission(AccessController.java:108)
at java.lang.SecurityManager.checkPermission(SecurityManager.java:544)
at java.lang.SecurityManager.checkPropertyAccess(SecurityManager.java:1297)
at java.lang.System.getProperty(System.java:382)
at java.lang.System.getProperty(System.java:366)
at org.eclipse.core.launcher.Main.run(Main.java:991)
at com.ibm.wsspi.bootstrap.WSPreLauncher.launchEclipse(WSPreLauncher.java:340)
at com.ibm.wsspi.bootstrap.WSPreLauncher.main(WSPreLauncher.java:110)
Exception in thread "Thread-5" java.security.AccessControlException: Access denied (java.io.FilePermission ...\temp\osgi_instance_location\Administrator\2069000401 read)
at java.security.AccessController.checkPermission(AccessController.java:108)
at java.lang.SecurityManager.checkPermission(SecurityManager.java:544)
at java.lang.SecurityManager.checkRead(SecurityManager.java:883)
at java.io.File.isDirectory(File.java:763)
at com.ibm.wsspi.bootstrap.WSPreLauncher.deleteEclipseInstanceArea(WSPreLauncher.java:586)
at com.ibm.wsspi.bootstrap.WSPreLauncher.onExit(WSPreLauncher.java:577)
at com.ibm.wsspi.bootstrap.WSPreLauncher$OnExit.run(WSPreLauncher.java:568)


Cause

Properties folder contains the server.policy file, when it's missing, server would not be able to start, and java.security.AccessControlException: Access denied exception is showing.


Diagnosing the problem

Check if the properties folder exists and if the content is correct.

Resolving the problem

Replace the properties folder from backup.

Document information

More support for: WebSphere Application Server
System Management/Repository

Software version: 6.1, 7.0, 8.0, 8.5

Operating system(s): AIX, HP-UX, Linux, Solaris, Windows

Reference #: 1628655

Modified date: 24 March 2013


Translate this page: