Technote (FAQ)
Question
An administrator is attempting to update a role template, however the individual is not able to find all of the object types listed under the 'Role Access Controls'
Cause
Object type is not part of (or not associated) to the business object model.
Answer
When an administrator attempts to do the following:
- Open a supported browser.
- Go the OpenPages URL.
- Login with an administrator id.
- Using the navigation menubar, go to: Administration -> Role Templates.
- Click on an existing role template.
- Click on the 'Edit...' button within 'Role Access Controls' section.
The listing within the 'Role Access Controls' section is not displaying all the available object types on the system.
To address the issue, the administrator needs to update the business object model such that the object types are directly or indirectly associated to the SOXBusEntity object type. To do so, an administrator can:
- Open a supported browser.
- Go to the OpenPages URL.
- Login with an administrator id.
- Using the navigation menubar, go to: Administration -> Object Types.
- Click on the object type that is not appearing.
- Review the parent associations and make sure the object type has at least one parent association.
- Then verify that that parent object type has a valid parent association (and repeat the process till the SOXBusEntity is reached).
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