Strange spaces / formatting when running "Group - Reports - Intercompany Report" due to Regional Settings

Technote (troubleshooting)


Problem(Abstract)

User clicks "Group - Reports - Intercompany Report". User chooses selection, and clicks "Run Report". However, the formatting looks 'wrong' (the numbers have spaces in them, instead of the expected commas (,)
If user clicks "Print" then the screen "Intercompany Report print preview" appears. Again, the formatting looks 'wrong' (the numbers have spaces in them, instead of the expected commas (,)
* If user clicks "Open spreadsheet" then the report opens inside Excel. Again the formatting looks 'wrong'.



Cause

There are other possible causes for standard reports formatting looking incorrect.

  • For example, see separate IBM Technote #1633637.

This Technote specifically relates to the scenario where the cause is a code production problem (defect PM89887) in Controller.
  • This defect is only triggered when the client device (e.g. end user's PC or end user's Windows user profile on Citrix/Terminal server) has been configured so that its regional settings have a 'space' configured to be the thousand separator.

Environment

On the client PC, inside "Control Panel" the user can launch the "Region and Language". Inside the "Formats" tab, the user can choose how their software displays its formatting.

  • By default, many regions (e.g. English UK) have the thousand separator set to a comma (,)
  • However, some regions (e.g. "Norwegian, Bokmal") have a different separator (e.g. "space"):

Resolving the problem

Fix:

Upgrade to later version of Controller (when available) which contains a fix for this issue.

  • TIP: to be automatically notified when this version is available, subscribe to APAR PM89887.

Workaround:

Modify the regional settings of the 'bad' end user(s) so that the "Region and Language" settings are configured to display the same way that the end user wants their reports to look.

Steps:

  1. Logon to the client device as the same 'bad' Windows user who has the problem
  2. Open "Control Panel"
  3. Open the regional settings (for most modern versions of Windows, this is "Clock, Language, and Region" - "Region and Language")
  4. Inside the "Formats" tab, change the "Format" to a region (e.g. "English (United Kingdom)") whose format matches what the user wants to see.
  5. Save changes and test.

Related information

1633637 - Large values are hyphenated (incorrect dash /
APAR PM89887

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Document information


More support for:

Cognos Controller
Controller

Software version:

10.1.1

Operating system(s):

Windows

Reference #:

1628301

Modified date:

2013-03-13

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