InfoSphere DataStage clients and dsjob commands fail to connect after a full suite installation of IBM InfoSphere Information Server 8.7 Fix Pack 2 on Windows

Technote (troubleshooting)


Problem(Abstract)

Following a successful full suite installation of 8.7 Fix Pack 2 on Windows, InfoSphere DataStage clients and dsjob commands might fail to establish connections to the InfoSphere Information Server engine. For InfoSphere DataStage clients, a pop-up box appears after the connection has timed out:

Failed to connect to Information Server Engine; hostname:port, project project.
(The connection has timed out (81015))

For dsjob commands, Status code = 81015 is reported.

Cause

When the install initiates the final start of the InfoSphere Engine Resource Service, a timing issue can leave NLS shared memory in a loading state. Subsequently, the InfoSphere DataStage server engine executables, such as dsapi_slave.exe, remain waiting for the NLS shared memory to be marked ready for use. The presence of load_shm_cat.exe and uvbootd.exe processes from the time of the install, and dsapi_server.exe and dsapi_slave.exe processes from the time a InfoSphere DataStage client was attempted are indications of this problem.

Resolving the problem

The problem can be fixed by performing the following steps:

1. Stop the load_shm_cat.exe, uvbootd.exe, dsapi_server.exe, and dsapi_slave.exe processes.

2. Stop and restart services through the InfoSphere DataStage Control Panel.


Cross reference information
Segment Product Component Platform Version Edition
Information Management InfoSphere Information Server

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Document information


More support for:

InfoSphere Information Server

Software version:

8.7.0.2

Operating system(s):

Windows

Reference #:

1627211

Modified date:

2013-04-14

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